Register  |   |   |  Calendar  |  Latest Topics
 
 
 


Reply
  Author   Comment  
jegibbons2000

VW Enthusiast
Registered:
Posts: 2
Reply with quote  #1 
Need some help.. I just bought a 1971 Standard Beetle and the turn signal switch and hazard switch needed replaced. I have installed both the new hazard switch and turn signal switch. Hazard lights work fine when pulling the switch. When I switch the turn signals left or right the green light in the dash comes on but none of the lights blink.

So far I have double checked the wiring and tried a new relay. With no change. Horn and dimmer switch work fine. I really could use some suggestions what to check next....

Thanks - James
0
ibl8382

VW Enthusiast
Registered:
Posts: 3
Reply with quote  #2 
I think you have no power to the turn switch,
behind the dashboard there is connection leading to the turn switch, check it out.

Regards
Ivan
0
Wayne

Avatar / Picture

VW Guru
Registered:
Posts: 1,716
Reply with quote  #3 
I had a similar problem that turned out to be a bad ground on the tailights.
__________________
Wayne Dean

Owner - http://www.allaircooled.com and http://www.superbeetles.com
0
jegibbons2000

VW Enthusiast
Registered:
Posts: 2
Reply with quote  #4 
Found the issue. I had a poor connection on my power connection. Problem fixed.

Thanks for the unput.....
0
Wayne

Avatar / Picture

VW Guru
Registered:
Posts: 1,716
Reply with quote  #5 
Nice find!
__________________
Wayne Dean

Owner - http://www.allaircooled.com and http://www.superbeetles.com
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation: